Increased traffic on www.prx.org
Incident Report for PRX
Resolved
We applied changes that are effectively blocking this unexpected traffic.
Posted almost 2 years ago. Jan 05, 2016 - 16:17 EST
Monitoring
We have seen increased traffic to prx.org, currently 20x normal, seemingly generated programmatically from specific ranges.

It resembles a DoS attack, but may be poorly created and misbehaving bots that are acting as one.

In either case, we are taking steps to block and minimize the impact of these requests, and the site is once again responsive.
Posted almost 2 years ago. Jan 05, 2016 - 13:06 EST