Emergency maintenance for prx.org at 5 pm ET
Incident Report for PRX
Resolved
Site is back online, downtime was only a few minutes.
Posted almost 3 years ago. Nov 13, 2014 - 17:07 EST
Monitoring
The load balancer for the prx.org website has a hardware problem and will be replaced at 5 pm ET.
We expect no more than 15 minutes of downtime.
Posted almost 3 years ago. Nov 13, 2014 - 16:46 EST